Monday, July 2, 2012

Python setuptools bootstrap errors

I ran into some errors installing py-dom-path 0.1 into my Win32 Python 2.7 installation. Here are the errors and their resolution.

The installation command I used was:

C:\...\python.exe C:\...\py-dom-xpath-0.1\setup.py install

Firewall

First, running in a corporate environment, the bootstrap script failed to access the network to download setuptools.

I needed to set an environment variable with the HTTP proxy details.

set HTTP_PROXY=user:pass@host:port

Old version of bootstrap script

The ez_setup.py bootstrap script included in py-dom-path 0.1 is out of date. It referenced an old version of setuptools that was no longer available: http://pypi.python.org/packages/2.7/s/setuptools/setuptools-0.6c9-py2.7.egg.

urllib2.HTTPError: HTTP Error 404: Not Found

I downloaded the latest version of the bootstrap script, placed it in the source directory and ran the installation again, this time with no problems.

No comments:

Post a Comment